It is currently Thu Dec 13, 2018 12:05 am


All times are UTC


Forum rules


Please click here to view the forum rules



Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Problems installing Wordpress with MySQL database
PostPosted: Sat Jul 09, 2005 2:06 am 
Noobie
Noobie

Joined: Sat Jul 09, 2005 1:20 am
Posts: 2
Hi, I've been looking into trying out some blog applications like b2evolution and bloxsom as i find blog providers like LiveJournal and Blogger not sufficient to my needs, and I wanted to try out WordPress as I've heard it's highly recommended but couldn't find out how to install it on this free host server.

I warn you now i'm a complete newbie at this and working with scripts and MySQL so I'm sorry if my questions seem a bit basic and the solutions pretty obvious.

I followed the WordPress instructions and first created a database and renamed and edited the wp-config.php file with the details of the database, username and password I had created, then uploaded all the files via FTP to the farvista server in the folder /www/marmoo7.farvista.net/

I then got an email with all my MySQL database details and it stated them to be:
Code:
username: marmoo7_wpblog
password: *******
database name: marmoo7_wpblog
database host: farvista.net
database port: 3306

In my initial edit of the wp-config.php file I'd simply written:
Code:
// ** MySQL settings ** //
define('DB_NAME', 'wpblog');     // The name of the database
define('DB_USER', 'marmoo7');     // Your MySQL username
define('DB_PASSWORD', '*******'); // ...and password
define('DB_HOST', 'localhost');     // 99% chance you won't need to change this value


I left the wp-confg.php file as it was anyway and tried to run install.php but only got this:

Code:
wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('../wp-config.php'); require_once('./upgrade-functions.php'); $guessurl = str_replace('/wp-admin/install.php?step=2', '', 'http://' . $_SERVER['HTTP_HOST'] . dirname($_SERVER['PHP_SELF']) ); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; header( 'Content-Type: text/html; charset=utf-8' ); ?>

hide_errors(); $installed = $wpdb->get_results("SELECT * FROM $wpdb->users"); if ($installed) die(__('
Already Installed
You appear to have already installed WordPress. To reinstall please clear your old database tables first.

') . ''); $wpdb->show_errors(); switch($step) { case 0: ?>
ReadMe documentation at your leisure.'), '../readme.html'); ?>


followed by some jumbled code that seemed to relate to the next few pages of the Wordpress Installation. I wasn't able to install WordPress so knew I couldn't have installed it before, and thought I'd just written the values in my wp-config.php file wrong.

So i changed the values in the wp-congi.php file on my computer to:
Code:
// ** MySQL settings ** //
define('DB_NAME', 'marmoo7_wpblog');     // The name of the database
define('DB_USER', 'marmoo7_wpblog');     // Your MySQL username
define('DB_PASSWORD', '*******'); // ...and password
define('DB_HOST', 'localhost');     // 99% chance you won't need to change this value

and deleted WordPress from my server and uploaded it again with the new wp-config.php file, but again found the same error and same problem.

I looked through the forum at MySQL database problems and read that farvista.net had had some problems with the database server so tried another free host allhyper.com, which also displayed the same error.

I went onto the WordPress help forum for some answers but could only find instructions stating to create a user and then create the MySQL database then add the user to that database, which doesn't work in the free web host setup as you create the database and give it a password and username at the same time i think.

I'm sure the problem lies somewhere in the MySQL database and the wp-config.php file and is probably something I'm doing wrong but I'm just not sure where the problem exactly lies.
Again sorry if this seems a very very simple question, but any sort of help would be appreciated :)


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jul 09, 2005 3:16 am 
Moderator
Moderator

Joined: Sat Feb 12, 2005 4:48 pm
Posts: 575
Location: Largo, Florida USA
Quote:
// ** MySQL settings ** //
define('DB_NAME', 'marmoo7_wpblog'); // The name of the database
define('DB_USER', 'marmoo7_wpblog'); // Your MySQL username
define('DB_PASSWORD', '*******'); // ...and password
define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value


Try changing "localhost" to "farvista.net" and see it that works

_________________
Bob G.

Grout Recoloring Systems: http://coloryourgrout.com

Save Your Data - Do Backups
http://forum.100webspace.com/viewtopic. ... highlight=


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jul 09, 2005 1:01 pm 
Noobie
Noobie

Joined: Sat Jul 09, 2005 1:20 am
Posts: 2
Hi, thank you for the reply and suggestion but I tried it and the same error comes up:
Code:
wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('../wp-config.php'); require_once('./upgrade-functions.php'); $guessurl = str_replace('/wp-admin/install.php?step=2', '', 'http://' . $_SERVER['HTTP_HOST'] . dirname($_SERVER['PHP_SELF']) ); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; header( 'Content-Type: text/html; charset=utf-8' ); ?>


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ]  Moderators: fhmagic, KJ, Moderators, Support Team

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
100WebSpace © 2011